О программе

Navigation: »No topics above this level«

О программе

 Return to chapter overview
Show/Hide Hidden Text

О программе НЛ-10м

Программа НЛ-10м разработана для версий Android 2.1 и выше. Предствляет собой виртуальный эмулятор авиационной навигационной линейки НЛ-10м.

Версия 1.0 (Релиз 27.02.2012г.)

Реализовано:

- Основные действия с линейкой (перемещения ползунков, визирки).

- Окно Настройки с выбором параметров.

- Меню с выбором действий.
Версия 1.1 (02.03.2012г.)

Исправлено:

- При смене экрана с ланшафта на портрет, линейка могла отобразится не корректно (растянуто), но после тапа по экрану было все нормально.

- При установке программы и первом запуске в настройках все пункты были включены по умолчанию, однако реально они были выключены, для включения необходимо было их перещелкнуть. Поставил все в выключено по умолчанию.

- При смещении верхней/нижней части линейки и выходе ее за край экрана происходило залипание тапа.

- При смещении центральной части линейки влево и отрыве ее правого края от края экрана, происходила деформация изображения этой части линейки.

Добавлено:

- Макет НЛ-10м внизу экрана. Если позволяет разрешение экрана, то ниже линейки отображается уменьшенная модель НЛ-10м с отображением видимой части (прямоуголльником) и положения визирки (красной линией). В этой версии макет пока не кликабелен. Отображение макета можно отключить/включить в настройках программы.

- В Настройках добавлено 2 пункта, 1 - включающий макет, 2 - убирающий заголовок программы (может пригодится для отображения макета НЛ-10 в ландшафтном экране)
Версия 1.2 (12.03.2012г.)

Исправлено:

- Центральная часть линейки смещалась только в пределах видимого экрана, а не вдоль всей линейки.

Добавлено:

- Макет НЛ-10м внизу экрана сделан кликабельным.

- В Настройках пункты разобранны по группам и добавлены пункты выбора цвета.

Все пожелания, предложения и найденые ошибки присылайте на AirLexa@yandex.ru , ICQ 475861800.


Главное окно

Navigation: »No topics above this level«

Главное окно

 Return to chapter overview

Вид Главного окна программы

В Главном окне программы отображена сама НЛ-10м и ниже ее, макет полного размера. На макете, прямоугольником синего цвета отображена видимая часть линейки в данный момент, красная линия показывает положение визирки на НЛ-10м.

Для смещения частей линейки необходимо нажать пальцем на нужную часть НЛ-10м и переместить его не отрывая от экрана, достигая желаемого положения подвижных частей линейки. Макет НЛ10м, который находится внизу экрана, тоже кликабелен, с его помощью можно перемещать все, кроме визирки.


Меню программы

Navigation: »No topics above this level«

Меню программы

 Return to chapter overview
Show/Hide Hidden Text

Меню программы НЛ-10м появляется при нажатии кнопки "Меню" на устройстве:

Перевернуть:

При каждом нажатии переворачивает линейку на другую сторону.
Визирку сюда:

Ставит визирку по центру видимой части линейки.
Придавить (Отпустить) визирку:

Придавливает визирку к центральной подвижной части линейки. После прижатия визирки она будет перемещаться синхронно с внутренней частью НЛ-10. Сам пункт меню изменится на "Отпустить визирку", выбор которого восстановит прежнее состояние визирки.
Настройки:

Открывает окно выбора настроек программы.
О программе:

Выводит на экран диалог с информацией об этой программе.
Выход:

Закрывает программу и выгружает ее из памяти устройства.


Настройки

Navigation: »No topics above this level«

Настройки

 Return to chapter overview
Show/Hide Hidden Text

Окно настроек программы выводится на экран, при выборе пункта меню Настройки.

Сохранять НЛ-10м:

Если включено, то положение частей линейки будет сохранено и восстановлено при последующем запуске программы. Если выключено, то НЛ-10м будет стартовать с нулевыми положениями.

Примечание: т.к. при смене ориентации экрана и вызове настроек происходит перезапуск главного окна, то при выключении данной настройки, положение НЛ-10 после этих действий будет обнуляться.
Показать макет НЛ-10м:

Если включено, то программа попытается показать ниже НЛ-10 ее макет в полный рост и если позволит разрешение экрана по высоте, то макет будет выведен на экран.
Скрыть статус-бар - Скрыть заголовок:

Если включено, то при запуске программа уберет верхний заголовок и верхний бар android по выбору. Это может помочь в показе макета НЛ-10 в ландшафтном режиме, т.к. увеличивает высоту используемой для рисования части экрана.

Примечание: применение этой настройки происходит только после перезапуска программы.
Взаимосвязь движения:

Если включено, то перемещение верхней/нижней части линейки потянет за собой центральную часть и визирку. Если выключено, то все части линейки ходят независимо друг от друга.

Примечание: если в меню влючено "Прижать визирку", то визирка синхронизируется с центральной частью при любом положении выключателя эгого пункта настроек.
Смещение по клику:

Определяет направление точного смещения деталей линейки при коротком тапе (тапе без смещения) на них в левой или правой части экрана. При этом коротком тапе, в зависимости от выбора галки, происходит смещение на 1 пиксель влево или вправо, кому как удобнее.
Выбор цвета (4 пункта):

Предназначены для настройки цвета визирки, цвета линии визирки, цвета прямоугольника видимой части НЛ-10м на макете и цвета визирки на макете. Номер цвета вводится в шестнадцатиричном формате (НЕХ). Узнать номер цвета в шестнадцатиричном формате можно в любом графическом редакторе или программе пипетки экрана. Например Just Color Picker: